Probleemloos updaten naar WordPress 5 (Gutenberg)

Een bestaande WordPress website zomaar updaten naar WordPress 5 (Gutenberg) raad ik af. Zorg ter voorbereiding in ieder geval voor het volgende:

  1. Een complete backup (inclusief database) van je website.
  2. Zoek uit of je thema en plugins geschikt zijn voor WordPress Gutenberg. De websites van de ontwikkelaars van het thema en de plugins geven waarschijnlijk aan wat de consequenties zijn van de update en welke voorbereidingen er nodig zijn.
  3. Check of de (database) serversoftware up-to-date is. De PHP versie moet namelijk minimaal 5.6 zijn (PHP 7.2 is de meest recente versie).

Twijfel je? Update nog niet en win eerst advies in.

Installeer eerst de Classic Editor Plugin

Nog een belangrijkste voorzorgsmaatregel: als je wilt updaten naar WordPress Gutenberg installeer dan in ieder geval  de Classic Editor Plugin (Nederlandse pluginnaam: "Klassieke editor"). Dat is een plugin (gemaakt door WordPress – Auttomatic zelf) die ervoor zorgt dat de Gutenberg editor wordt uitgeschakeld.

Update 12 december 2018: WordPress heeft versie 5.01 uitgebracht. Na het uitvoeren van die update wordt de Classic Editor plugin soms al automatisch geïnstalleerd. Je ziet dan deze melding bovenaan het dashboard:

Uiteraard wel verstandig om even te checken of dit ook daadwerkelijk is gebeurt, of de plugin ook actief is en met welke instellingen. Dat laatste kun je zien via Instellingen – Schrijven (zie ook de afbeelding daarover hieronder).

Instellingen van de Classic Editor

Als je de Gutenberg (Block) Editor wilt gebruiken voor eenvoudige pagina's en daarnaast ook voor complexere pagina's je vertrouwde page builder plugin wilt gebruiken (die nog niet werkt in combinatie met de block editor), schakel dan de volgende optie in:

Klik na aanpassen van de instelling onderaan de pagina op de knop 'Wijzigingen opslaan'.

Je kunt nu per pagina kiezen of je deze wilt wijzigen met de Gutenberg (Block) editor of met de Classic Editor:

WordPress websites met page builders updaten naar WordPress Gutenberg

Het installeren van de Classic Editor Plugin is met name van belang als je template (thema) werkt op basis van een page builder (zoals bijvoorbeeld de Avada Fusion Builder, de Visual Composer, de Enfold Page Builder en de Site Origin Page Builder).

Als de producent van de page builder die jij gebruikt zijn software nog niet geschikt heeft gemaakt voor WordPress Gutenberg dan kun je na de installatie van de klassieke editor plugin je pagina's nog steeds op de (oude) vertrouwde manier blijven bewerken, zoals beschreven in de vorige paragraaf.

Eenvoudige WordPress websites updaten naar WordPress Gutenberg

Als je een eenvoudig thema in gebruik hebt zonder page builder plugins of andere plugins die gebruik maken van de oude editor (zoals in mijn video hieronder), dan gaat er waarschijnlijk weinig mis. WordPress zet je bestaande pagina's automatisch over naar de Gutenberg editor. De teksten en afbeeldingen worden opgenomen in een blok van het type Klassiek. Je kunt dat zo laten, of je splitst de bestaande content op in afzonderlijke blokken voor titels, paragrafen, lijsten en afbeeldingen met de ingebouwde optie 'Omzetten naar blokken'.

Zo werkt de Classic Editor plugin

In de onderstaande video laat ik het volgende zien:

  • Hoe je de Classic Editor plugin installeert
  • Hoe je een pagina opent met de Klassieke editor
  • Hoe je een pagina opent met de Gutenberg editor
  • Hoe je een Klassiek (content)blok omzet in afzonderlijke Gutenberg blokken
  • Hoe je een blok bewerkt
  • Hoe je een blok verwijdert

Reageer jij als eerste?

Geef een reactie